[permanent link to this page]
The Carfree Universe Project (CFU) has been archived.
Guest Login

Changelog 3

A list of technical changes to carfreeuniverse.

Added by portal_administrator #16 on 2004-12-21. Last modified 2008-03-05 14:58. Originally created 2004-12-21. F0 License: Public Domain
Location: World
Topics: site documentation, sitedoc: changelog

This is Changelog 3. It is no longer being updated (2006-01-27-0757).

Latest entry


1611 I've been on this for the past two days--Saturday was getting a version of CFU running on my own computer, and solving that Intro document creation date issue. Yesterday was upgrading epoz and and upgrading my local install to Zope 2.7 and cmf 1.5. I believe freezope runs zope 2.6 and cmf 1.4 right now.

1616 today, wrote up a document to help me remember how to export the server from freezope to my local computer to make it easier in the future.

some known issues to work on:

  • many of the docs I made I added a base href to to simplify my table of contents and other links. I need to remove these and fix the links and and also reduce absolute links in my docs and use relative ones instead. The updated epoz/wysiwig helps with this. Hard coded urls that use the full server path do not work when I download the server and run it on my own computer.
  • I will also eliminate the trailing slash on the base href for Document objects, and I'll need to go through and do both of these changes and fix any documents that get messed up because of them. Hoboschool needs fixing and others.
  • need to separate custom into more directories as it is getting slow displaying all those ZPTs
  • deletereply seems not to work for portal admin after moving to zope 2.7.
  • related to problems mentioned above: zope 2.7 cmf 1.5 is eating the base hrefs I added face it, get rid of them.
  • Content object actions need some tweaking both for 2.7 and anyways.
  • Need to fix some problems with addDoc and addLink...
that's it
1625 -- I have .5 hr to make the important changes and then get to try exporting and importing the thing again.

1633 addDoc, addLink, addMyImage, addMyNewsItem all modified.

1642 folder_contents action re-added (had been removed so would not display when one is already viewing the contents)

1649 will have to work on fixing all the docs, like hoboschool, offline, and then add them all at once.


1617 moving topic and topics out of custom and into custom_queries resulted in this error:

    KeyError: macros

    Module Products.PageTemplates.TALES, line 220, in evaluate
    URL: /ZopeHosting/freezope/ea.freezope.org/cfu/l
    Line 34, Column 0
    Expression: standard:'here/topic/macros/displayTopic'

So I put them back for now.

1621 I also made talkback (comment) trees always expand fully, and updated some links.

1631 and did some preparation for fixing the base href problem.

1635 and earlier I made information about personal subjects more accessible on the metadata_edit_form.


0525 Made "add content" action not visible when

folder = 'Favorites'
since I keep inadvertently adding stuff there.

Actions could probably be sorted out better. Maybe it would be good to have "add content to /memberID" be always available.

0721 Wow. I did some pretty inefficient things because I did not understand how actions worked-- for example - to change the actions across the top bar (the user actions), go to the portal_membership folder. There is some rather inefficient stuff in the actions conditions still, and I wonder how this slows things down.

0734 I put add to Favorites in with the global actions.

I could change "my stuff" to "my folder" or something nice.

I could remove undo

0752 discovered a bug: when I try to run addtofavorites on a link, I get the following error:

  can only concatenate tuple (not "list") to tuple 

for line 41 in addToFavorites.py

I also want to fix that script to put /view on the ends of links to images.

0812 well, I cannot mess with this any more now. Known issues:

  • undo isn't working... or maybe only works some of the time.
  • addToFavorites errors on links-- for some reason getting a tuple not a list.

Someday maybe I'll fix these.

0816 it seems like undo works, but it is not handled gracefully. I just undid adding a link, and it worked but kicked me into a login screen. 1018

1038 All right. Clearly I have a problem. Implemented a delete_item action of dubious value.

1041 An alternative would have been to improve upon set view filter to list only private items. But Looking at that it seems like I might not be able to change it through the web.

1113 I'll make it a workflow action and make it only visible when the item is private.

1126 that looks good. All done for now.


0439 Issue: www.carfreeuniverse.org and carfreeuniverse.org are not the same... I should do like google does and turn one of those domains off --> have carfreeuniverse.org redirect to www.carfreeuniverse.org

0716 for some unknown reason, older docs have their membersFavoring stored as a list ([]), while newer docs, and items have their membersFavoring stored as a tuple. This is what broke addToFavorites.

0753 I fixed that with the following:

   if same_type(membersFavoring,(1,)):
          #property created post migration; is a tuple
          memberToAdd = (member,)
          #property created pre migration; is a list
          memberToAdd = [member]
        context.manage_changeProperties(membersFavoring=membersFavoring + memberToAdd)

0920 removing tal:content="python:capwords(subject) from lines 49 and 35 of topics.pt

Well, only removing the capwords part. It is less pretty, but people typing in topics/subject by hand won't be confused by the caps-- as this is case sensitive.

0927 did the same in index_html in members dir. and also the call to:

   capwords nocall: modules/string/capwords; 

Maybe I should have used stylesheets?? It looks like I'm not using the zpt ptopics.


1033 The date/time modified in the byline of content objects now links to a publicly-accessible content_status_history page. The following files were modified:

  • createAndSetDefaultLocationProperties.py
  • addPropertyToExistingPortalContent.py
  • content_status_modify.py
  • content_status_history.pt
  • contentByline.pt

1802 Have fixed document editing so that pressing the "change" button when using "edit (old)" returns user to the old editor, not to the wysiwyg editor. The following files were modified:

  • document_edit.py
  • document_edit_form.pt

began working on that at 1707.


1217 beginning work updating live CFU with changes made off line,plus some new changes.

1218 factoring Members/index_html and locating the logic with rest of skins.

1231 the favorites_page needs to be referred to just above:

    <!-- not: is_Members_dir & allononepage-->

1234 Beginning adding new member properties

1243 Factored favorites list using macro.

1249 done adding properties... Now will add the new scripts.

1304 scripts added--may not have had to use .py extensions. Now will update Members_index, viewThreadsAtBottom. etc.

1313 donatable needs to be proxy manager.

1315 adding user action "my home" pointing to home page of member--going to myStuff is useless for me--without adding something to the view filter-- since it has 300+ items.

1330 forgot to update contactable script... had not noted that I changed it.

1335 updated email_form

1338 getMemberObject also needs proxy manager.

1339 what next.

1343 updated viewthreadsatbottom

1343 the email script is returning not contactable.

1346 this is what has been modified (via cadaver) so far:

     contactable   genMailtoLink.py    obfuscateEmail.py
     donatable.py  getMemberObject.py  printMemberUrl.py
     email_form    getOwnerId.py       viewThreadsAtBottom

1350 Problem was-- the context.- so now using getMemberObject

1352 doesn't like the view appended on the redirect url after sending the email.

1456 well it has been a mess- adding a came_from variable to email form so we can return people to the right place... properly.

1458 also, it looks like email_form cannot be called with the trailing slash or it will not work... hmm.

1556 well that business seems to be resolved-- later I will remove the old links to email_admin... yeech that was a drag, and unexpected, but simpler in the logron...

now just metadata edit form, and personalization form... and backup and leave!

1606 forgot to add getPersonalSubjectList

1625 forgot to add donationMessageFormat prop, correct Moneybookers

1634 added custom_process/donate + images

1635 getting an error on personalize form...:

    ValueError: unpack sequence of wrong size

1638 in obfuscateEmail line 42

1643 arrgh also forgot to update personalize script!!!

1647 well
I only broke my data- othres should be fine... so backup and go!!


1508 printMemberUrl was doing:

        print (the thing)
        return printed

That was putting in a newline and this was showing up in the errorlogs... Should have checked to see if pages validated after all those changes.

1527 messing with error log- trying to figure out where the errors come from, but the bots just seem messed up-- except for that first problem I found.

1529 begin updating live web-- start with member properties:

1539 done with props.

1543 donate, personalize* all updated. That should be it.

1545 adding condition member/useExternalEditor to portal_type actions.

1609 the wireless net went down-- so I moved and plugged in...

1613 what fun-- they put us in the closed section of a massive deserted lab--there is one other guy... Ah, the campus when school is out is a special place.


1235 Stephen / steve of WCN got url searching set up for the WCD--eventually every region page here will have a link to db results for there. Here's the syntax so far:

  • http://www.worldcarfree.net/directory/search.php?country[]=france&searchnow=1
  • http://www.worldcarfree.net/directory/search.php?region[]=california&searchnow=1
  • http://www.worldcarfree.net/directory/search.php?city=london&searchnow=1

I'm not sure how to query on superregion yet.


0716 spent a lot of time getting email_form to return nothing if not called in right place. Could not figure out how to return a moved permanently code using zpt-- well I have a guess, but the current approach will at least keep errors from filling up the logfiles from spiders that indexed the old email_form location.

0729 Got an action added to the cmf actions tool, external_edit that checks for the user's preference useExternalEditor. This is not as good as the solution possible with cmf 1.4.7, but it will do for now. and gives those who don't use the thing one less button to be confused about.

0735 well, external_edit doesn't work on links. I won't worry about hiding for now since I'm probably the only one using it.

0743 I made so it only shows up for news items and documents...

0803 Well, I need to quit working on programming. So I'll make a few basic changes to make the site more presentable I hope and leave off with major projects until later, like the donation page. It wouldn't have to be that major except for how I am trying to do it.

0806 first,

0934 the delete action I added a while back was breaking user registration when the user wanted to have their password mailed to them... To fix it, instead of checking the portal workflow status, I gave it the permission of "modify portal content"... people are unable to modify published things so this has the same effect--preventing deletion of published objects.

0940 As I was saying-- it is now policy that the URL for all objects will end in a trailing slash. I will start with the main page.

0941 oh- I just prettied up the joining process and the documentation how to create and publish the new user's documentation.

1220 straightened out news item editing.

1221 the change I wanted to make was to get everything pointing to an object to put the trailing slash on the URL. So I'll work on that now.

1238 Well that worked well-- now have to go through topics, locations, etc. listings, and fix the old documents that don't have trailing slashes in their links...

1300 will do same for member index and query results.

1329 would be nice to get breadcrumbs to reflect this change!

1344 I think we have everything but breadcrumbs taken care of, and all the actual content, of course.

1905 Took care of breadcrumbs

1946 need to fix byline...

1948 and link to aboutcfu

2022 so I have it set that urls ending in view and form do not get trailing slashes... I need to work on refining the actions to make sure the trailing slashes are corresponding.

2023 the ref to content_status_history I'm giving a trailing slash... the distiction is supposed to be related to whether something is an object or a method of an object. In that case content_status_history should not have a trailing slash. But I'll leave it as it is for now.

2027 same goes for folder_contents

2218 very nice. I found a way of finding out where breadcrumbspy is being called from. So here is the true definiton of whether a trailing slash should be used or not:

    publishedObj = context.REQUEST.PUBLISHED
    if hasattr(publishedObj,'meta_type'):
        #referring to the 'view' method of an image was causing the script to break because PUBLISHED was returning 'bound method Image.view of <image name>'
        finalChar = ''
        if publishedObj.meta_type not in ['Page Template', 'Script (Python)','Filesystem Page Template']:
            #is a content object with methods

            #finalChar = '/' + context.REQUEST.PUBLISHED.meta_type
            #finalChar = '/' + str(context.REQUEST.PUBLISHED)
            finalChar = '/'
        #is a method or a query
        finalChar = ''
    bookmarks = joinChar.join(links + [callersid + finalChar])  

2224 so, content_status_history does not get a trailing slash.

2227 there is still a bug...

2244 For some reason my last two entries saying that everything looks good and that I hope I'm done with programming for a while and can focus on content now didn't get saved. So i'm saying it again.


1907 member page for those with personal items and n>26 is now using the expensive getPersonalSubjectList... no longer is it only called on the metadata form some of the time... perhaps a less expensive implementation will be needed.


1145 I went to publish a news item today and found email wasn't working. So now it is disabled. Who knows how long it has not been working? I have been thinking of moving cfu to nidelven but that would take time, effort, money (but not that much money). However it is good to help freezope, since they have helped me. Often I feel I'm the canary in the mine however, when it comes to reporting problems... Maybe in a year I'll move, but I need to study Spanish now, and for the foreseeable future.


0846 began work on cfu local, index page

0849 modded so far:

  • local.pt X
  • index_html_utils X
  • myGetRoster.py X
  • roster.html X
  • main_template X
  • index_html X
  • myTruncate.py X
  • new folder old in custom- put local_pt in there, before updating
  • displayTopics.py X
  • zptstylesheet. X
0859 myGetRoster.py
listed members with nothing published will no longer be listed. List sorted by nItemsPublished.

1720 think I'm done.

1721 let's do the update.

1740 update finished-- backup & so long!

1802 By default all members are listed now...


0915 here working on CFU

1026 abandoning attempt at including link descriptions on main page, i.e. making a new links display like the new documents display.

1029 I think I'm at my limit with this though there was more I wanted to do.

1153 done with this for this week--- Mostly cleaning up of old documents remains.


0935 completed display of personal topics in both location and topic queries. Updated FilterResults.py, topic.zpt, and FeatureDocumentation. Probably 1hr last night-- found / remembered the problem when browsing offline copy of site. maybe 1hr at about 1838 yesterday.


1715 removed trailing slash from the getBaseTag template ( changed /> to >. So now documents validate. But I'm wondering why the spiders were getting urls like hoboschool/join_form. Maybe that problem is fixed now.

1735 I saw it was in fact the links in viewThreadsAtBottom. These are fixed now. That's it then!


1007 removed option to add folders from the folder factories page. The message for that content object said "use folders to put content in categories" or something like that. In fact we want people to use metadata to put content in categories.

1008 note also that attempting to delete folders causes an error:

   No workflow provides "review_state" information.

I think this is due to a bug that has been fixed in newer versions of CMF. But since no one should be adding folders now, this should not be an issue. Thanks to leto for pointing this out (an historic first or second user-reported bug!! (user who is not colin, that is))


1055 the bug is mine, but may not be fixed. beginnigg work on letting users specify width of edit boxes.

1123 finished adding working save & edit and save & view buttons to metadata edit form. Script did not have to be modified... It works for docs. will it work for other things?

1242 looks like I have working implementation. Now just need to spread it around so that all edit boxes refer to it. It uses session variables.

  • metadata_edit form
  • epoz_edit form
  • news_item edit
  • email_form
  • comment_form
  • should use a macro.

1400 some cruft:

   <div metal:use-macro="here/formMacros/macros/setFormSize|default" tal:omit-tag="">default content here</div>

1411 all that work and there is an incredibly easy solution:

   <textarea name="text:text" rows="20" cols="70" wrap="soft" style="width: 100%"
       tal:attributes="cols here/getEditBoxWidth;
                       rows here/getEditBoxHeight;"></textarea>

1412 the key is the style attribute. I don't even need the other feature.

1521 Think I'm all done with that. yes.

1548 added check spelling link to doc edit forms.

1611 updated creative commons license links and metadata tool metadata policy for "rights"

1613 think that is all for now... now dealing with content issues. Then backup and leave..


1626 since 1412 working on adding actual document title to title tag and in displaying meta tags and dublin core metadata. Doing this may improve search engine rankings. We'll see.


1640 Linkage to the World Carfree directory is now complete!!! we still need to iron out some of our name differences (I need to change "new york city" to "new york" for example). But the link is there for all locations at the region, city, and country level!


1655 shocked that "VHPM draft 1" came up first under ecovillages, I resolved to change the display for topics. So since about 1400 worked on fixing the display of topics. Much more functional now. May add showing and hiding of descriptions later. Default sort is to have newly created docs at the top.


1626 A bit foolishly, since about 1000, Have been working on this.

  • got main page querying off catalogofpublisheditems. Not sure why I couldn't get the rest of site working off that catalog, but gave up after a while. If I got everything working off that catalog, things should be faster then....
  • improved link and document views (i.e. the links page and the documents page)
  • added little image from wikipedia next to all links that points to external link.

that is it... I've also been asking Ivo at freezope to help me return www.carfreeuniverse.org to all requests for carfreeuniverse.org, since I found out one can be logged in at www. but not at . and other issues related to listing in search engines and access log listings.

Now... to rest and read spanish. Some major improvements have been made, and I don't forsee any new ones for a while!!


1244 added caching for locations, topics, links, and documents. It is ram caching as accellerated HTTP .. seemed to have no effect. They should be cached for an hour. but i see a lot of cache "misses".


1707 just noticed that "Descriptions" for the "new documents" were broken... don't know how I missed it before. added it to cat of pub itemsmetadata and now all ok.


1408 It only took 4 hrs, but I now have a reverse-video epoz editor. To use it, select the "reverse video" skin in your preferences. There were a few strange bugs/ (and one actual mechanical problem) that made this take so long. The point to remember here is that I had to modify and name correctly epoz_blank_iframe.html.pt.

1657 It only took 3 more hours, but now I've made the reverse video skin work nicely in all parts of the site. I at least am now free of the brite white screen, at least once I log in.

1734 Well, I spoke a bit too soon. Now the reverse video skin may be working as well as the basic skin. That's all until next thursday, probably.


1238 made default skin the reverse video. If you hate this change, complain to me or login to your account and choose the "basic" skin to get the old view back.


1239 So, the problem was that emails set using the forms were rejected by freezope's spam filter.... who knows how many emails were lost. So, I've added a new property trySendingFormEmail, so I can turn that off separately from all the other email functions... It may be working now, but I should not mess with this any more at the moment, and the thought of more emails going off into the void, emails that were ment for the authors, does not excite me.

I also made email images that show up on the black background, and changed the rest to PNGs which look better with the anti-aliasing, but may not show up on older browsers... the new images are with georgia bold 24 pt font, made using gimp. The site is still working!! Freezope is still up!! so far! and has been working well, I think.


1639 O.k. for maybe 2hrs I've been working on this. Someone emailed me about the critical mass email list. Sometimes people think my page is the page, not about the link. In any event, I noticed the breadcrumbs--that is, the path at the top of the page (e.g.: cfu/ Members/ colin/) was not terribly obvious as links--quite possibly people would never find their way to the rest of the site, when the search engine dumps them on a sub-page!!

So I made the links at the top of the page match the style of the standard links. One thing led to another, and I had to fix some CSS problems (lightgrey), and then I changed the font to use Georgia by default. And then I made sure the css validated. That's all.


0736 1619 debugging localcfu:

    python: path('repeat/item/length') - path('repeat/item/index')

in custom_queries/content_listing_macros in place of:

    "repeat['item'].length - repeat['item'].index"

0737 1828 found other bug-- referring to location with final/ slash-- causes the link to top to lead to infinite depth, e.g., /Bogota/Bogota/Bogota/top

1835 content_byline: $xregionQuoted- remove trailing slash.

1850 think I have it:

    string: ${here/absolute_url}/$term/top

in template "l" in custom_queries

1907 now more complicated (only part of last line changed- rest for reference):

    <div tal:omit-tag="" tal:define="field python: locationTranslationDict.get(traverse_subpath[0],traverse_subpath[0]); symbol python: traverse_subpath[0]; term python:traverse_subpath[1]">

    <div tal:omit-tag="" tal:define ="topLevelOnly python: traverse_subpath[-1] =='top'"> 

    <a href="top" tal:condition="python: not topLevelOnly and field <>'neighborhood'" tal:attributes="href string: ${here/absolute_url}/l/$symbol/$term/top">Top level only</a>

0742 previously last statement was:

   <a href="top" tal:condition="python: not topLevelOnly and field <>'neighborhood'" tal:attributes="href string:$term/top">Top level only</a>

0744 and must define symbol.

0747 done. Those bugs were found when making a plucker copy of cfu using sunrise. The infinite recursion meant the site never finished being spidered. It never ended. The plucker copy works well. I put a copy of the plucker version of CFU made on 12/29/2005 on my rohan page (3,339KB). It includes greyscale pictures.


1431 beginning yearly update of CFU. Will probably only include: adding of originalcreationdate field, and maybe some mods to the front page.

1442 will add prop originalCreationDate to images and to documents.

1445 the text search for this site is not very helpful. Replace w/ google??

1531 for some reason metadata_edit_form_favorite was never really implemented/ completed??

1532 modded actions for favorite type to use this form.

1534 at this point-- addImage.py and metadata_edit_form have been updated. Need to make sure I can change originalCreationDate. Using metadata form.

1536 updating metadata_edit.py

1550 ok. We have it working for the new image we added. Now to add prop to all images and docs. Then to index it. And to start using it. At first, just display it in byline.

1554 addDoc modded.

1559 thinking of just adding prop to all content. Then using originalCreationDate across the board. only allowing it to be changed for images and documents. Seems simpler.

1601 we can add it to the other types later if it seems to be aproblem.

1613 think we're in business with docs and images. Now getting catalogs to index it.

1619 added originalCreationDate to indexes in cat of pub items and portal_catalog. Updated cat of pub. . . now portal_cat.

1649 I think we're in business. And it is time to go. Need to back up site however. Will do in outdoor office?? Used a style tag to make date not italic. See content_byline. Yay!

This log continues at Changelog 4.

Portal Administrator <>    

To comment on this document, login (you must have already joined).

v? c? 
about this site